Artikel weiterleiten
Artikel editieren
Afdrukweergave
FAQ #2544

Wat is STRATO PHP Extended Support?

In dit artikel vind je alle informatie over STRATO PHP Extended Support.

INHOUD
•    Wat is PHP en wat doet het op je website?
•    Waarom heb je STRATO PHP Extended Support nodig?
•    Wanneer hebben we je geïnformeerd over STRATO PHP Extended Support?
•    Waarom brengen we STRATO PHP Extended Support in rekening?
•    Wanneer start STRATO PHP Extended Support?
•    Weet je niet zeker of je STRATO PHP Extended Support überhaupt nodig hebt?
•    Waarop moet je letten voordat je STRATO PHP Extended Support uitschakelt?
•    Hoe kun je STRATO PHP Extended Support uitschakelen?
•    Je wilt je scripts aanpassen aan een hogere PHP-versie, maar hebt meer tijd nodig?

 

Wat is PHP en wat doet het op je website?

PHP is een veelzijdige scripttaal die de basis vormt voor veel dynamische websites en content management systemen, zoals WordPress, Joomla en Prestashop. De PHP-community ontwikkelt PHP als programmeertaal continu verder. Zo komen regelmatig nieuwe functies beschikbaar en worden veiligheidslekken gedicht.

Wat is STRATO PHP Extended Support?-1.png

 

In de PHP-community is de ondersteuning van PHP 5.3 al sinds 14 augustus 2014 stopgezet. Deze versie heeft dus geen ondersteuning meer. Kwetsbaarheden en problemen worden niet langer verholpen.
De support voor PHP-versie 5.6 stopt op 30 december 2018, voor PHP-versie 7.0 op 3 december 2018.

Daarom verzorgt STRATO voortaan updates voor je. Tot nu toe hebben we dat gratis gedaan, ondanks de hoge personeelskosten die hierdoor ontstaan.

Wat is STRATO PHP Extended Support?-2.png

 

Gebruik je nog steeds een verouderde PHP-versie?

Dan heb je een e-mail van ons ontvangen waarin we erop wijzen dat we deze versie in de toekomst alleen nog via STRATO PHP Extended Support ondersteunen. Dit geldt ook voor bijvoorbeeld veiligheidspatches. PHP Extended Support is een betaalde dienst van STRATO die ervoor zorgt dat je website blijft beveiligd tegen aanvallen, zodat je alle tijd hebt om over te schakelen naar een actuele PHP-versie.


Waarom heb je STRATO PHP Extended Support nodig?

Op je webspace staat PHP-inhoud met een verouderde PHP-versie. Waarschijnlijk heb je deze verouderde versie in de STRATO klantenlogin of via een .htaccess-bestand gekozen.
Hoe je de instelling in de klantenlogin wijzigt, lees je in onze FAQ: Zo wijzig je de PHP-instellingen in je pakket.

Wij raden je aan om altijd de nieuwste PHP-versie te gebruiken. Op dit moment is versie 7.2 aanbevolen. Hiermee kun je ook de nieuwste versies van populaire applicaties gebruiken zonder verdere compatibiliteitsproblemen.

 

Wat is STRATO PHP Extended Support?-1.png

 

Wanneer hebben we je geïnformeerd over STRATO PHP Extended Support?

Wij hebben je onlangs per e-mail geïnformeerd over de wijzigingen rond STRATO PHP Extended Support. Misschien heb je deze e-mail gemist. Controleer in dat geval of het e-mailadres dat je bij STRATO hebt opgegeven, nog klopt. Wij sturen alle informatie over je contract namelijk óók naar dit adres.
Hoe je dit e-mailadres controleert en wijzigt, lees je hier: Hoe wijzig ik mijn klantgegevens?

 
Waarom brengen we STRATO PHP Extended Support in rekening?

STRATO PHP Extended Support is een speciale, betaalde service voor onze hostingklanten. Aangezien de PHP-community de ondersteuning van verouderde PHP-versies stopzet, neemt STRATO het onderhoud van deze verouderde PHP-versies over vanaf het moment dat de officiële support stopt. STRATO PHP Extended Support heeft dus niet alleen betrekking op versie 5.3, maar ook andere PHP-versies die niet meer worden ondersteund. Op deze manier kunnen wij je een ononderbroken service bieden voor je website. Ook voorkomen we zo dat je site kwetsbaar wordt voor hackers die de lekken in verouderde PHP-versies gebruiken.
Wil je meer informatie over de verschillende PHP-ondersteuningsfasen en de volledige PHP-levenscyclus? Lees dan dit overzicht:

Wat is STRATO PHP Extended Support?-1.png 

 

Verouderde PHP-versies op de webspace van onze klanten creëren mogelijk beveiligingsproblemen. Die kunnen het gehele hostingplatform en daarmee de veiligheid van andere klanten in gevaar brengen. Volgens onze algemene voorwaarden ben je als STRATO klant verplicht om ervoor te zorgen dat je software up-to-date blijft. Voldoe je niet aan deze verplichting? Dan moeten wij eventuele veiligheidslekken voor je repareren. Maar het onderhoud van verouderde PHP-versies leidt voor ons tot flinke beheerlasten. De kosten van deze extra service brengen wij je in rekening via een kleine maandelijkse vergoeding. Omdat wij ervan uitgaan dat je de bestaande PHP-scripts nodig hebt voor je website, hebben wij STRATO PHP Extended Support voor jouw contract al geactiveerd. Je PHP-scripts blijven dus werken. Gedetailleerde informatie heb je per e-mail van ons ontvangen.

Wanneer start STRATO PHP Extended Support?

STRATO PHP Extended Support voor versie 5.6 start 5 maart 2019 en voor versie 7.0 op 5 februari 2019.
Voor nieuwere versies begint STRATO PHP Extended Support op het moment dat de PHP-community stopt met de ondersteuning. Vanaf deze datum krijgt de desbetreffende PHP-versie immers geen onderhoud meer. Ook sluit de PHP-community dan geen veiligheidslekken meer.

Weet je niet zeker of je STRATO PHP Extended Support überhaupt nodig hebt?

Met een paar stappen kun je snel testen of je site ook op een nieuwere PHP-versie kan werken. Om het risico te minimaliseren dat je site tijdelijk niet beschikbaar is, raden wij de volgende procedure aan.
•    Maak eerst een kopie van je website in een nieuwe map.
•    Maak een subdomein aan en leid dat door die nieuwe map.
•    Vervolgens kun je met een .htaccess-bestand in die nieuwe map overschakelen naar de huidige versie PHP 7.2 (of versie 7.1).

Ga nu met je browser naar dit subdomein en controleer of de kopie van je website probleemloos werkt. Zo ja, kun je voor je ‘echte’ website ook deze nieuwere PHP-versie kiezen. Dat doe je eenvoudig in de STRATO klantenlogin. Wil je meer informatie? Lees dan het FAQ-artikel Zo wijzig je de PHP-instellingen in je pakket.

Zodra je een nieuwe PHP-versie hebt ingesteld en de klantenlogin verlaat, kun je niet meer terug naar de oudere PHP-versie 5.3. Controleer dus eerst alle functies van je website vóór je uit de klantenlogin uitlogt.

 

Waarop moet je letten voordat je STRATO PHP Extended Support uitschakelt?

Schakel je over naar een actuele versie van PHP die community-ondersteuning heeft? Controleer dan eerst of je site nog steeds goed werkt. Pas dan is het zinvol om STRATO PHP Extended Support uit te schakelen. De betaalde support stopt vervolgens aan het einde van de maandelijkse termijn.

Hoe kun je STRATO PHP Extended Support uitschakelen?

Om de betaalde service STRATO PHP Extended Support uit te schakelen, ga je eerst naar de klantenlogin. Kies daar in het menu op Databases en webspace en vervolgens PHP-versie instellen.
 

Wat is STRATO PHP Extended Support?-1.jpg

 

Om over te schakelen naar een actuele PHP-versie selecteer je de gewenste versie en kies je Opslaan.

Wat is STRATO PHP Extended Support?-1.jpg

 

Wat is STRATO PHP Extended Support?-2.jpg

 

Heb je de service uitgeschakeld, maar merk je dat er nog problemen zijn met je website? Dan kun je binnen de supportlooptijd teruggaan naar de oude PHP-versie.


Je krijgt dan de informatie dat wij de ondersteuning aan het einde van de contractlooptijd uitschakelen. In ons voorbeeld is dit 6 november 2017. Ga dan terug naar het Overzicht en klik op Uitschakelen.

 

Wat is STRATO PHP Extended Support?-4.jpg

Wat is STRATO PHP Extended Support?-5.jpg

 

Wij verzoeken je te bevestigen dat alle noodzakelijke instellingen zijn doorgevoerd. Pas dan is de deactivering voltooid en stoppen we de ondersteuning aan het einde van de contractlooptijd.

Je wilt je scripts aanpassen aan een hogere PHP-versie, maar hebt meer tijd nodig?

Controleer eerst of je scripts überhaupt moeten worden aangepast. Veel scripts zijn namelijk compatibel met actuele PHP-versies en werken dus prima. Heb je tóch een script dat je moet aanpassen? Dan kun je STRATO PHP Extended Support blijven gebruiken tot je deze aanpassing hebt doorgevoerd.


×
Heeft dit artikel je geholpen?    ja / nee