WordPress 5.5: alles over de nieuwe versie

WordPress 5.5: alles over de nieuwe versie

In WordPress 5.5 draait (alweer) bijna alles om de editor. Maar er zijn andere interessante nieuwe functies waarvan je website zal profiteren.

De focus van de WordPress-update naar versie 5.5 ligt opnieuw op de blokeditor. De ontwikkelaars hebben veel moeite gestopt in het verbeteren van de block-directory. Ook kunnen themes en plug-ins nu automatisch worden bijgewerkt in plaats van handmatig in het dashboard. WordPress ondersteunt nu bovendien Lazy Loading en maakt automatisch sitemaps aan.

Wijzigingen in de editor

Alle blokken in oogopslag

De ontwikkelaars hebben voornamelijk de block-directory onder handen genomen. Als je linksboven in de editor op het plus-icoontje klikt, ontvouwt zich een menu met alle beschikbare blokken. De verschillende subcategorieën zoals opmaak, layout, embeds en widgets hoeven niet meer apart geopend te worden. Dit overzicht kun je nu ook tijdens het schrijven geopend houden, zodat je snel het blok vindt dat je nodig hebt.

WordPress 5.5: block-directory als overzicht bij het schrijven van je blogpost
Block-directory: alle blokken in één oogopslag

Blokken snel zoeken en vinden

Ook het zoeken in de block directory is iets uitgebreider. Mocht je onder een bepaalde zoekterm geen blokken vinden, verschijnt eventueel een plug-in als alternatief. Als je bijvoorbeeld een speciaal auteurvak aan een bericht wilt toevoegen, typ je “author” in de zoekopdracht. Als de editor het gewenste blok niet bevat, zie je als het goed is een of meerdere blokplug-ins opduiken.

WordPress 5.5: zoekfunctie in de block-directory
Zoeken in de block directory: blok niet gevonden? Misschien is er een plug-in die verder kan helpen.

Foto’s bewerken in de editor

De nieuwe afbeeldingseditor ziet er beter uit. Maar belangrijker is: je kunt afbeeldingen nu rechtstreeks in de editor bijsnijden. Het originele bestand blijft behouden – WordPress slaat de aangepaste versie op in de mediabibliotheek.

WordPress 5.5: foto's bijsnijden in de editor
Een foto bijsnijden kan nu terwijl je schrijft

Automatische updates voor plug-ins en thema’s

Voorheen moest je plug-ins en themes updaten via het dashboard. Vanaf WordPress 5.5 kun je deze updates automatiseren. Navigeer hiervoor naar het plug-in-overzicht (Plug-ins -> Geïnstalleerde plug-ins) en selecteer “Inschakelen auto-updates”.

WordPress 5.5: plug-ins kunnen nu automatisch worden geactualiseerd dankzij de functie auto-updates.
Automatische update van plug-ins

Het werkt op dezelfde manier met themes. Klik op je theme (Weergave-> Thema’s) en vervolgens in de theme-details op de bijbehorende link.

WordPress 5.5: je thema automatisch laten updaten dankzij auto-updates
Je ontvangt automatische de laatste updates voor je theme

WordPress XML-sitemaps

Een sitemap is een dynamische inhoudsopgave voor zoekmachines. Het helpt Google, Bing en andere zoekmachines om de inhoud van je website vast te houden en in de zoekresultaten te presenteren. Tot nu toe had je speciale plug-ins zoals All in One SEO Pack of Yoast SEO nodig om zo’n sitemap aan te maken. WordPress 5.5. genereert automatisch de XML-sitemap en slaat deze op in de hoofddirectory. Je kunt het bestand oproepen door wp-sitemap.xml in te voeren achter je domein (bijvoorbeeld jouw-domein.nl/wp-sitemap.xml).

Via de Google Search Console heb je de mogelijkheid om Google te informeren over jouw sitemap. Hierdoor kan Google jouw website beter presenteren in de resultaten. Dit verhoogt de zichtbaarheid en dus het aantal bezoekers op je site.

WordPress 5.5: geen plug-ins meer nodig om XML-Sitemaps aan te maken
Sitemap van WordPress

Lazy Loading

Ook voor Lazy Loading was tot nu toe een plug-in nodig. Met deze functie worden afbeeldingen pas geladen zodra het gedeelte van de pagina waarop ze staan in beeld komt. Dit verhoogt de (gevoelde) prestatie van een website, want niets is vervelender dan een langzaam ladende website. WordPress ondersteunt nu dus eindelijk Lazy Loading van huis uit. Dit maakt je website niet alleen sneller, maar verbruikt ook minder bandbreedte.

WordPress wordt zichtbaarder, sneller en veiliger

Met WordPress 5.5 hebben de ontwikkelaars goed werk geleverd. De nieuwe block-directory is een echte stap voorwaarts. Je kunt de blokken die je zoekt met een paar klikken vinden en plaatsen.

De implementatie van Lazy Loading maakt plug-ins voor dit doel overbodig. Dit geldt niet per se voor SEO-plug-ins: hoewel WordPress automatisch een XML-sitemap maakt, kunnen Yoast en andere plug-ins nog veel meer. Om ervoor te zorgen dat je niet ineens twee XML-sitemaps hebt, kan het handig zijn om oude sitemap-plug-ins tegen het licht te houden en indien nodig te deactiveren.

Automatische updates voor themes en plug-ins hebben niet alleen voordelen. De functie brengt het risico met zich mee dat je website niet meer werkt als bijvoorbeeld geüpdatete plug-ins of themes incompatibel zijn met je WordPress-versie . Activeer daarom de automatische updates alleen voor themes en plug-ins van ervaren en betrouwbare auteurs (bijvoorbeeld Automattic).

Zoekwoorden:

Delen

  1. Avatar

    brigitte zei op

    ik ben echt niet blij met de update , na de update deed onze site helemaal niets meer.
    we hebben het thema opnieuw aangekocht the 7 ,maar we zijn nu heel wat pagina’s kwijt.
    geen idee waar ze gebleven zijn ik was eindelijk blij het wat onder de knie te hebben en zo de site zelf bij te kunnen houden. maar nu zakt me de moed echt in de schoenen, ik heb geen idee hoe ik het weer goed moet krijgen , van een mooie goed draaiende website hebben we nu 1 grote puinzooi. Het is dat we als stichting verplicht zijn een website hebben in verband met de anbi status , anders had ik hem gewoon opgedoekt want ik wordt van deze ellende niet vrolijk is er geen mogelijkheid dat je gewoon onder een oudere versie kan blijven draaien en hebben we dan misschien weer alles terug zoals het was

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste Brigitte,

      Wat vervelend om te horen dat de WordPress-update in dit geval niet goed heeft uitgepakt. Helaas kan dit af en toe voorkomen, doordat bijvoorbeeld gebruikte plug-ins of themes verouderd zijn, en niet compatibel met de nieuwste WordPress-versie. Vooral om veiligheidsredenen is het belangrijk om toch altijd de laatste updates te installeren.

      Ik zie dat je inmiddels telefonisch contact hebt gehad met mijn collega. Zij heeft je een aantal tips gegeven. Ik hoop dat het daarmee gelukt is om de problemen te verhelpen. Mocht je toch nog hinder ondervinden, laat het zeker even weten!

      Met vriendelijke groet,
      Sjef

      Beantwoorden

Je kunt pas een reactie plaatsen nadat je ons privacybeleid en cookies hebt geaccepteerd. Om privacyredenen mogen wij jouw persoonsgegevens anders niet verwerken.

Klik onderaan de pagina op de blauwe button OK. Nadat je de pagina opnieuw hebt geladen, kun je een reactie achterlaten.

 

Deze website maakt gebruik van cookies voor onder andere Google Analytics. Deze melding verdwijnt zodra je de cookies hebt geaccepteerd. Meer informatie