Belangrijk: binnenkort is PHP Extended Support voor PHP 7.4 beschikbaar

Belangrijk: binnenkort is PHP Extended Support voor PHP 7.4 beschikbaar

De community-ondersteuning van PHP 7.4 is in november 2022 gestopt. Om ervoor te zorgen dat je deze versie tóch kunt blijven gebruiken, bieden wij je de service PHP Extended Support aan. Maar wat houdt deze dienst in? In dit blog lees je het.

PHP Extended Support: alle informatie op een rij

Eerder schreven we er op ons blog al over. PHP Extended Support is een handige dienst in ons portfolio. Heb je het gemist? In dit artikel lees je wat deze dienst precies inhoudt.

Belangrijk om te weten: het bovengenoemde artikel gaat weliswaar over de oudere PHP-versies, maar het is inhoudelijk nog steeds up-to-date.

Belangrijk vanaf februari 2023

De PHP-community faseert de technische ondersteuning voor verouderde PHP-versies stap voor stap uit. Dit betekent bijvoorbeeld dat veiligheidsupdates niet langer automatisch worden geïnstalleerd, en dat de infrastructuur na verloop van tijd niet meer voldoet aan de huidige normen. Voor een soepel en veilig functionerend contentmanagementsysteem zijn deze zaken echter noodzakelijk.

Daarom is onze PHP Extended Support zo waardevol. Wij zorgen ervoor dat jij je website veilig kunt blijven gebruiken en ondersteunen je hiertoe met een onderhoudsservice voor verouderde PHP-versies. Belangrijk: wij bieden je geen nieuwe functies. Wij zorgen er alleen voor dat de oude PHP-versie veilig en goed blijft werken. Je bepaalt zelf of je upgradet naar een nieuwe versie of dat je een oude versie blijft gebruiken.

Vergelijking tussen een actuele PHP-versie en Extended Support
Een actuele PHP-versie gebruiken of gebruikmaken van PHP Extended Support? De voor- en nadelen in een overzicht.

Betaalde ondersteuning van PHP 7.4

Gebruik je momenteel PHP 7.4? Dan biedt de PHP-community sinds november 2022 geen ondersteuning meer. STRATO biedt je de dienst PHP Extended Support in eerste instantie gratis aan. We willen namelijk dat je genoeg tijd hebt om over te stappen naar een nieuwere PHP-versie.

Wil je ook hierna van PHP Extended Support gebruik blijven maken? Dan worden er kosten in rekening gebracht. Uit veiligheidsoverwegingen raden wij je echter aan om tóch te upgraden naar een actuelere versie. De meest actuele versie is PHP 8.1, maar de community support voor PHP 8.0 loopt nog t/m 26 november 2023. Vanaf wanneer je voor de PHP Extended Support moet betalen, kun je terugvinden in de klantenlogin.

Timeline voor PHP Extended Support
Timeline voor PHP Extended Support

De timeline van de community-support

In onze grafiek zie je een overzicht van de PHP-versies die nu en in de toekomst worden ondersteund. In de regel houdt de community een versie gedurende drie jaar bij. Community-ondersteuning voor PHP 8.0 zal naar verwachting eindigen in november 2023 en voor PHP 8.1 in november 2024.

STRATO PHP Extended Support biedt je support wanneer PHP-versies verlopen. Je kunt daardoor veilig oudere versies blijven gebruiken.

Wil je PHP Extended Support activeren? Dat kan snel en gemakkelijk in de STRATO klantenlogin.

Zoekwoorden:

Delen

  1. Rob zei op

    Mijn WordPress website (versie 6.1.1) is volledig bijgewerkt qua plugins, themes. Toch heb ik geen werkende website wanneer ik de PHP versie overschakel van 7.4 naar 8.0 (alleen wit scherm). Ook niet wanneer ik alle plugins en themes uitschakel. WordPress 6.1.1 zou volledig compatibel moeten zijn met PHP versie 8.0. Ik heb dus alle plugins en themes al uitgeschakeld gehad en ook dit geeft geen resultaat. De htaccesss file is initieel en beïnvloed de PHP versie welke ik in het Strato klantenportaal selecteer niet.

    Wat gaat hier fout? Voor zover ik kan beoordelen ligt het niet aan de WordPress installatie aangezien deze, met alle themes en plugins uitgeschakeld, qua versie (6.1.1) gewoon zou moeten werken i.c.m. PHP versie 8.0.

    Ik zie de reactie graag tegemoet.

    Beantwoorden
    • Jorrit van der Heide zei op

      Beste Rob,

      Bedankt voor je vraag. Jammer dat de PHP-upgrade problemen oplevert. Wat je nog zou kunnen proberen:

      Schakel de WordPress debug modus in voordat je overschakelt naar PHP 8.0. Mogelijke problemen kunnen zich daar al manifesteren.

      Maak een nieuwe back-up. Voordat je overschakelt naar PHP 8.0, deactiveer je alle plug-ins en schakel je als test over naar een nieuw standaardthema. Als het nu werkt, zou ik stap voor stap het thema en de individuele plug-ins activeren.

      Hopelijk lukt het!

      Hartelijke groet,

      Jorrit

      Beantwoorden
  2. Ronald zei op

    Sinds de upgrade naar PHP 8.0 werkt mijn site ook niet meer. Ik heb alles geupgrade wat mogelijk was en nog steeds deze error: Er heeft zich een kritieke fout voorgedaan op deze site. Daarna alle plugins uit gezet, geswitched naar 8.0 en later weer terug gezet omdat dat het probleem niet oploste. Nu ben ik het Thema aan het checken maar kan het niet vinden: theme47830 Versie: 3.1.5. Is deze compatibel? En als het zo is, welke andere opties heb ik nog waarom het niet werkt? BVD!

    Beantwoorden
  3. Wouter Huizer zei op

    Hallo, als ik de upgrade doorvoor naar PhP 8.0 krijg ik op alle pagina’s van de website ‘404 Error’. Oops! That page can’t be found. Ik heb in een testomgeving gechecked wat er mis kan zijn, de permalinks opnieuw gegenereerd, maar het probleem blijft zich voordoen. Wat kan hier aan de hand zijn? En hoe kan ik er voor zorgen dat ik wel kan upgraden?

    Beantwoorden
    • Jorrit van der Heide zei op

      Hallo Wouter,

      Bedankt voor je vraag. Vervelend dat de PHP-upgrade complicaties oplevert.

      Zijn alle plug-ins en het thema up-to-date? Is het thema en de gebruikte plug-ins ook compatibel met PHP 8.0? Dit is o.a. herkenbaar in de beschrijvingen of de documentatie. Neem indien nodig contact op met de auteurs van de plug-ins of het thema.

      Schakel de WordPress debug modus in voordat je overschakelt naar PHP 8.0. Mogelijke problemen kunnen zich daar al manifesteren.

      Maak een nieuwe back-up. Voordat je overschakelt naar PHP 8.0, deactiveer je alle plug-ins en schakel je als test over naar een nieuw standaardthema. Als het nu werkt, zou ik stap voor stap het thema en de individuele plug-ins activeren.

      Zie ook het artikel: https://www.strato.nl/blog/nog-sneller-wordpress-op-php-8-1-draaien/

      Hartelijke groet,

      Jorrit

      Beantwoorden
  4. Henk distelvelt zei op

    Heb al jaren een zelfgebouwde applicatie. Het connecten doe ik volgens de geadviseerde coding echter die werkt niet meer met php 8.0. Als ik die code vervang met de nieuwe commando’s lukt het connecten ook niet meer terwijl de ohp8.0 checker geen problemen ziet. Wat nu?

    Beantwoorden
  5. Fred zei op

    Als ik PHP 8.0 instel, dan werkt Coppermine niet meer. Ik zie geen foutmelding, maar de pagina laat alleen nog de Coppermine menu balk bovenin zien en geen foto’s.

    Met PHP 8.1 en 8.2 werkt het ook niet.

    Ook zie ik geen upgrade voor Coppermine staan bij de Website-Apps.

    Hoe kan ik dit oplossen? Ondersteunen jullie Coppermine met een recente versie van PHP?

    Beantwoorden
    • Jorrit van der Heide zei op

      Beste Fred,

      Bedankt voor je reactie. Inderdaad lijkt het CMS Coppermine niet probleemloos op de nieuwe PHP-versie te draaien. Uit hun website leid ik af dat het CMS al langer niet meer is geactualiseerd.

      Op hun forum vond ik de volgende tip met betrekking tot PHP 8.0:

      “Daarna schakelde ik over van 1.5.48 naar CPG Release 1.6.21 ( https://github.com/coppermine-gallery/cpg1.6.x/releases/tag/v1.6.21 ).

      Specifieker:
      Belangrijk: deactiveer vooraf alle 1.5.xx-plug-ins, anders ontstaan ​​er problemen na installatie.
      dan
      – Download de huidige versie 1.6 en pak deze uit op uw computer.
      – Alle bestanden overschreven met Filezilla behalve anycontent.php en de map albums met de nieuwe versies (gelukkig had ik de Strato-servergegevens al van tevoren opgeslagen in de Filezilla-servermanager.)
      – voer het updatescript erover uit,
      – Verwijderde of overschreven overbodige of verouderde bestanden.
      – de (nieuwe) plugins geactiveerd of geïnstalleerd.

      Daarna werkte de database (in wezen) weer. Alle speciale tekens zijn nu echter onleesbaar geworden.” (bron: https://forum.coppermine-gallery.net/index.php/topic,80658.msg390063.html#msg390063)

      Ik hoop dat je daar iets aan hebt. Helaas kan ik je geen positiever antwoord geven.

      Hartelijke groet,

      Jorrit

      Beantwoorden
Meer reacties tonen

Je kunt pas een reactie plaatsen nadat je ons privacybeleid en cookies hebt geaccepteerd. Om privacyredenen mogen wij jouw persoonsgegevens anders niet verwerken.

Klik onderaan de pagina op de blauwe button OK. Nadat je de pagina opnieuw hebt geladen, kun je een reactie achterlaten.

 

Deze website maakt gebruik van cookies voor onder andere Google Analytics. Deze melding verdwijnt zodra je de cookies hebt geaccepteerd. Meer informatie