Uitgebreide webhosting-service: STRATO PHP Extended Support voor PHP 5.3

Uitgebreide webhosting-service: STRATO PHP Extended Support voor PHP 5.3

Heb je een hostingpakket van STRATO? Dan hebben we belangrijke informatie voor je: vanaf 18 september 2017 bieden we geen gratis support meer aan voor de verouderde PHP-versie 5.3. Deze versie krijgt al sinds 2014 geen ondersteuning en veiligheidsupdates meer van de PHP-community.

We raden je daarom om veiligheidsredenen aan een actuele PHP-versie voor je website te installeren. Mocht dat niet meteen mogelijk zijn voor jou, hoef je je geen zorgen te maken. Je kunt dan namelijk onze betaalde dienst STRATO PHP Extended Support bestellen. Daarmee kun je PHP 5.3 veilig blijven gebruiken tot je een nieuwere versie op je website hebt kunnen installeren. Weet je niet welke optie voor jou geschikt is? In dit bloginterview vertelt onze technisch directeur René Wienholtz welke vragen je jezelf moet stellen en welke voor- en nadelen er zijn.

Hallo René. In september is er een belangrijke wijziging op het gebied van webhosting. Om wat gaat het precies?

Allereerst een kleine toelichting. We willen hosting voor onze klanten zo prettig mogelijk maken. Daarom ondersteunen we al jarenlang oudere PHP-versies zoals PHP 5.3, die van de PHP-community geen veiligheidsupdates meer krijgen. We weten dat onze klanten deze support nodig hebben, omdat de verhuizing naar een actuele PHP-versie technisch erg lastig kan zijn. Zo zijn niet alle plug-ins compatibel met een nieuwe PHP-versie.

Deze complexiteit is de afgelopen jaren toegenomen. Er zijn intussen actuele PHP-versies die toch niet voor elke klant geschikt zijn. Veel klanten van STRATO gebruiken nog steeds PHP 5.3 in plaats van PHP 5.6 of PHP 7.0. En hoewel deze versie verouderd is, willen we toch de best mogelijke support bieden. Daarvoor hebben we nu een uitgebreide dienst geïntroduceerd.

Voor de technische support van PHP 5.3 moeten klanten betalen. Waarom?

We willen onze klanten ook in de toekomst veiligheidsupdates voor PHP 5.3 bieden. Dit doen we door correcties en updates voor nieuwe versies te porteren naar de oudere versie. Dit vergt echter steeds meer tijd en moeite, zowel in de technische ontwikkeling als bij het testen. We moeten namelijk niet alleen omvangrijke tests uitvoeren van al deze updates voor PHP 5.3, maar ook voor de wijzigingen aan andere delen van het platform. Deze complexiteit ontstaat door de grote veelvoud aan alt-versies voor scripttalen. En om in de geest van #faireenvoudigd te blijven: deze processen kosten duidelijk meer dan we dachten. Omdat we deze support niet zomaar willen stopzetten en onze klanten niet willen dwingen tot een upgrade, kiezen we voor het aanbieden van een betaalde service.

Handig overzicht: Extended Support van PHP 5.3 en de support van actuele PHP-versies door de PHP-Community.

Is dat dan fair?

Met dit aanbod verhogen we het comfort voor onze klanten. Het alternatief zou zijn om PHP 5.3 helemaal niet meer aan te bieden. Je moet namelijk niet vergeten dat klanten die een verouderde PHP-versie gebruiken, meestal óók een veiligheidsgevoelig CMS-systeem als WordPress of Joomla gebruiken. Hierdoor bestaat het risico dat hackers de webspace misbruiken om klantgegevens te stelen of het gehackte CMS gebruiken om spam te versturen. In dat geval moet onze abuse-afdeling de website van de klant blokkeren.

Wat kan een klant doen als hij deze service niet wil gebruiken?

Natuurlijk willen we onze klanten bewust maken van de voordelen van een door de PHP-community gesupporte versie. Daarmee profiteren ze van een moderne infrastructuur en van ondersteunde features, veiligheidsupdates en andere verbeteringen.

Uiteindelijk moet elke klant zich afvragen of hij PHP 5.3 nodig heeft. Is de upgrade naar een actuele versie veel werk? Stel dat de klant in het voorjaar van 2018 een nieuwe website wil introduceren. Dan kan hij tot die tijd misschien beter nog even wachten met het omzetten naar een actuelere PHP-versie.

Met welke kosten moet de klant rekening houden?

De support van PHP 5.3 kost € 3,18 per maand inclusief btw. Deze prijs dekt onze kosten. De betroffen klanten hebben in een persoonlijke e-mail van 26 juli meer informatie gekregen over de concrete stappen. Vanaf die datum hebben klanten twee maanden de tijd om een actuele PHP-versie te installeren. Dat kunnen ze het beste doen via de STRATO klantenlogin. Kiezen de klanten geen actuele versie, dan krijgen ze na het verstrijken van die twee maanden automatisch STRATO PHP Extended Support.

In de STRATO klantenlogin kun je gemakkelijk een nieuwe PHP-versie instellen.

Als klant kun je deze dienst maandelijks opzeggen, nadat je in de klantenlogin een actuele PHP-versie hebt gekozen. STRATO geeft je voor elke betaalde maand een servicegarantie. Het volgende is echter goed om te weten: zodra de PHP-community stopt met de ondersteuning van PHP 5.6. is een backport, oftewel de support van PHP 5.3 voor ons waarschijnlijk niet meer mogelijk. Uiterlijk dan is het dus de hoogste tijd om na te denken over een nieuwe PHP-versie.

De PHP Lifecycle: deze grafiek geeft een overzicht van de supportfases voor de verschillende PHP-versies.

Dank je wel René!

Zoekwoorden:

Delen

Je kunt pas een reactie plaatsen nadat je ons privacybeleid en cookies hebt geaccepteerd. Om privacyredenen mogen wij jouw persoonsgegevens anders niet verwerken.

Klik onderaan de pagina op de blauwe button OK. Nadat je de pagina opnieuw hebt geladen, kun je een reactie achterlaten.

 

Deze website maakt gebruik van cookies voor onder andere Google Analytics. Deze melding verdwijnt zodra je de cookies hebt geaccepteerd. Meer informatie