Belangrijk: binnenkort is PHP Extended Support voor PHP 5.6 en 7.0 beschikbaar

Belangrijk: binnenkort is PHP Extended Support voor PHP 5.6 en 7.0 beschikbaar

De community-ondersteuning van PHP 5.6 en 7.0 stopt binnenkort. Om ervoor te zorgen dat je deze versies tóch kunt blijven gebruiken, bieden wij je de service PHP Extended Support aan. Maar wat houdt deze dienst in? In dit blog lees je het.

PHP Extended Support: alle informatie op een rij

Eerder schreven we er op ons blog al over. PHP Extended Support is een handige dienst in ons portfolio. Heb je het gemist? In dit artikel lees je wat deze dienst precies inhoudt.

Belangrijk in 2019

De PHP-community faseert de technische ondersteuning voor verouderde PHP-versies stap voor stap uit. Dit betekent bijvoorbeeld dat veiligheidsupdates niet langer automatisch worden geïnstalleerd, en dat de infrastructuur na verloop van tijd niet meer voldoet aan de huidige normen. Voor een soepel en veilig functionerend contentmanagementsysteem zijn deze zaken echter noodzakelijk.

Daarom is onze PHP Extended Support zo waardevol. Wij zorgen ervoor dat jij je website veilig kunt blijven gebruiken en ondersteunen je hiertoe met een onderhoudsservice voor verouderde PHP-versies. Belangrijk: wij bieden je geen nieuwe functies. Wij zorgen er alleen voor dat de oude PHP-versie veilig en goed blijft werken. Je bepaalt zelf of je upgradet naar een nieuwe versie of dat je een oude versie blijft gebruiken.

Vergelijking tussen een actuele PHP-versie en Extended Support
Een actuele PHP-versie gebruiken of gebruikmaken van PHP Extended Support? De voor- en nadelen in een overzicht.

Betaalde ondersteuning van PHP 5.6 en 7.0

Gebruik je momenteel PHP 7.0? Dan heb je vanaf 3 december 2018 geen community-ondersteuning meer. Voor gebruikers van PHP 5.6 geldt: deze versie heeft vanaf 1 januari 2019 geen community-ondersteuning meer.

STRATO biedt je de dienst PHP Extended Support in eerste instantie gratis aan. We willen namelijk dat je genoeg tijd hebt om over te stappen naar een nieuwere PHP-versie.

Wil je PHP Extended Support daarna nog gebruiken? Dan betaal je € 3,18 per maand incl. btw. Uit veiligheidsoverwegingen raden wij je echter aan om tóch te upgraden naar een actuele versie, zoals PHP 7.1 of 7.2. Vanaf wanneer je voor de PHP Extended Support moet betalen, kun je terugvinden in de klantenlogin.

 

Uitgebreide timeline voor de STRATO PHP Extended Support
Timeline voor PHP Extended Support

De timeline van de community-support

In onze grafiek zie je een overzicht van de PHP-versies die nu en in de toekomst worden ondersteund. De versie PHP 7.2 staat hier nog niet vermeld. In de regel houdt de community een versie gedurende drie jaar bij. PHP 7.2 is sinds 30 november 2017 beschikbaar en wordt naar verwachting tot november 2020 ondersteund.

STRATO PHP Extended Support biedt je support wanneer PHP-versies verlopen. Je kunt daardoor veilig oudere versies blijven gebruiken.

Wil je PHP Extended Support activeren? Dat kan snel en gemakkelijk in de STRATO klantenlogin.

Delen

  1. Avatar

    Jeroen Muijsson zei op

    Ik heb de website op Strato zelf gemaakt met een eenvoudig ‘word-achtig’ programma dat u als Strato zelf aanbiedt. Heet het niet ‘Live pages’. Zoiets. Nu mailt u mij iets wat gaat over PHP. Ik heb geen idee wat u bedoelt en vindt ook dat je zo niet met je klanten om moet gaan.

    Als de onderliggende software die die Live Pages aanstuurt verouderd is los dat dan zelf op door het op de nieuwere versie te laten draaien en val mij er niet op deze nogal technische manier mee lastig. Want ik weet echt niet waar u het over heeft.

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste Jeroen,

      Bedankt voor uw vraag. Het klinkt in dit geval alsof u de dienst PHP Extended Support niet nodig heeft. Ik heb mijn collega bij onze klantenservice gevraagd dit te bekijken en zij zal met u hierover contact opnemen.

      Mocht u nog vragen hebben, hoor ik het natuurlijk graag.

      Ik wens u alvast fijne feestdagen toe!
      Sjef

      Beantwoorden
  2. Avatar

    Yassine Achrah zei op

    Ik ben bezig met het opzetten van een webshop via WordPress, maar vanwege mijn thema heb ik een PHP versie voor een limiet van 256MB. Zit deze bij mijn pakket inbegrepen of moet deze geupgrade worden?

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste Yassine,

      Bedankt voor je vraag. Klopt het dat je vraag betrekking heeft op de PHP-instelling memory_limit (het maximaal toegestane geheugengebruik van een PHP-script)? De waarde van deze PHP-instelling hangt bij STRATO inderdaad samen met de gebruikte PHP-versie. In het volgende FAQ-artikel vind je de specifieke waarden per PHP-instelling en PHP-versie:

      https://www.strato.nl/faq/hosting/zo-wijzig-je-de-php-instellingen-in-je-pakket/

      Vanaf PHP-versie 7.1 is de waarde voor memory_limit inderdaad 256 MB.

      Ik hoop dat dit je vraag beantwoordt. Zo niet, hoor ik het natuurlijk graag!

      Met vriendelijke groet,
      Sjef

      Beantwoorden
  3. Avatar

    André Linting zei op

    Mijn website is gebaseerd op WordPress. Moet ikzelf actie ondernemen of wordt deze update door WordPress zelf doorgevoerd?

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste André,

      Bedankt voor je vraag. Ook wanneer WordPress gebruikt, zul je zelf in de STRATO klantenlogin de PHP-versie moeten wijzigen (of de betaalde PHP Extended Support moeten activeren, mocht je van een oude PHP-versie gebruik willen blijven maken).

      Gebruik je de meest recente versie van WordPress? Dan draait deze ook het beste onder een nieuwe PHP-versie. WordPress zelf raadt voor de nieuwe WordPress-versie 5.0 het gebruik van PHP-versie 7.3 aan. Het is wel aan te raden om vooraf ook te checken of je gebruikte thema en eventuele plug-ins compatibel zijn met een nieuwere PHP-versie. Deze informatie kun je bijna altijd terugvinden op de website van het gebruikte thema of plug-in.

      Ik hoop dat deze informatie je verder helpt. Mocht je er niet helemaal uitkomen, dan laat het zeker weten!

      Met vriendelijke groet,
      Sjef

      Beantwoorden
  4. Avatar

    Frank Balje zei op

    Klinkt allemaal erg heftig als men er geen of weinig verstand van hebt. Mogelijk doen jullie het erg belangrijk overkomen om commercieel gezien een schrikreactie teweeg te brengen zodat men nu snel naar een maandelijkse bijdrage overstapt, dat vind ik een slechte vaststelling betreffende STRATO als klant zijnde.
    Kunt u in gewone mensentaal eens uitleggen in uw blog hoe het nu zit. Ik begrijp dat ik gewoon deze site kan aanhouden en niets hoef te doen en ik dan alleen geen community ondersteuning meer heb (Whatever dat ook is!!!). Dus niets doen als je tevreden bent.

    Ik hoor het graag.
    met vriendelijke groet,
    Frank

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste Frank,

      Natuurlijk help ik je graag verder. PHP is een scripttaal, waarop het grootste deel van de websites is gebaseerd. Om ervoor te zorgen dat jouw website online ook zichtbaar is, draait er op onze servers PHP-software. Deze software is gratis en wordt ontwikkeld door de PHP-community. PHP wordt voortdurend verder ontwikkeld, er worden dus telkens nieuwe versies uitgebracht. De oudere versies worden, nadat er een nieuwe versie is uitgekomen, nog een paar jaar voorzien van noodzakelijke veiligheidsupdates. Wanneer deze veiligheidsupdates niet zouden worden uitgevoerd, wordt het erg makkelijk voor hackers om websites of servers binnen te dringen. Je kunt dit bijvoorbeeld vergelijken met een oude computer met Windows XP als besturingssysteem.

      Wanneer er geen updates meer worden uitgebracht, is het aan te raden over te stappen naar een nieuwe PHP-versie. In de meeste gevallen is dit geen probleem. Websites die ten tijde van PHP 5.6 zijn gemaakt, werken doorgaans ook nog onder PHP-versie 7.2 of 7.3. Het kan echter zijn dat bepaalde elementen van een website niet meer goed functioneren met een nieuwe PHP-versie. Wanneer je een oud computerprogramma hebt dat gemaakt is voor Windows XP, kan het zijn dat dit ook niet meer werkt onder Windows 10.

      Als klant bij STRATO heb je de keuze. Je kunt bij ons voorlopig ook oudere PHP-versies blijven gebruiken. Dit kan alleen doordat wij zelf intern veiligheidsupdates voor deze oude versies blijven doorvoeren (waar dit voorheen gratis gebeurde door de PHP-community). Om deze kosten te dekken, wordt de dienst “PHP Extended Support” in rekening gebracht.

      Het is absoluut aan te raden om over te stappen naar een nieuwe versie van PHP. Dit is niet alleen veiliger, maar je website wordt hierdoor vaak ook sneller en je hebt de beschikking over nieuwe features. In de meeste gevallen levert de wissel naar een nieuwe PHP-versie geen problemen op. Er bestaat echter een klein risico dat bepaalde elementen van je website na een overstap niet meer goed werken. Daarom is het verstandig om dit vooraf te checken. Ik zie dat je WordPress gebruikt voor jouw website. Controleer daarom of je de meest recente WordPress-versie hebt geïnstalleerd. Check daarnaast of je gebruikte thema en plug-ins ook compatibel zijn met een nieuwe PHP-versie, en of er updates beschikbaar zijn.

      Als je niets doet, zul je van de verouderde PHP-versie gebruik blijven maken. Je maakt dan ook automatisch gebruik van de dienst “PHP Extended Support”. Hiervoor zullen vanaf februari (PHP 7.0) of maart (PHP 5.6) kosten in rekening worden gebracht.

      Ik hoop dat mijn antwoord je wat meer duidelijkheid geeft. Mocht je nog vragen hebben, hoor ik het natuurlijk graag.

      Met vriendelijke groet,
      Sjef

      Beantwoorden
  5. Avatar

    Cor Struyk zei op

    Ik gebruik momenteel nog 1 website via Strato, welke ik met een vrij eenvoudige Engels programma, Serif Webplus X8, heb gemaakt. Ik stuur de files altijd met FileZilla via FTP naar Strato. Volgens mij gebruik ik geen specifieke zaken waarvoor PHP nodig is ? Zou u dat eens willen nakijken voor mij ? Bvd

    Met Vr. Groet
    Cor Struyk

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste Cor,

      Bedankt voor je vraag! Ik heb je website kort bekeken, en het lijkt erop dat deze geen gebruikmaakt van PHP.

      Toch staan er waarschijnlijk wel PHP-scripts op je webruimte, anders zou je namelijk de nieuwsbrief over PHP Extended Support niet hebben ontvangen. Wellicht heb je in het verleden eens een website op basis van PHP op je webruimte geplaatst?

      Wanneer er op dit moment geen actieve websites op basis van PHP op je webruimte staan, kan het in ieder geval geen kwaad om in de STRATO klantenlogin over te stappen naar een hogere PHP-versie.

      Met vriendelijke groet,
      Sjef

      Beantwoorden
  6. Avatar

    Niqui zei op

    Ik heb vandaag mijn php omhoog gedaan naar de nieuwste versie geloof ik maar nu kan ik niet meer in mijn admin komen op wp. Ik krijg een witte pagina. De website zelf is nog wel online. Wat nu?

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste Niqui,

      Vervelend om dit te horen. Ik zie dat je over dit probleem inmiddels ook contact hebt gehad met mijn collega’s van de klantenservice. Het inlogscherm van je WordPress-site lijkt ook weer bereikbaar te zijn. Klopt dit?

      Mocht je nog problemen ondervinden, hoor ik het graag!

      Met vriendelijke groet,
      Sjef

      Beantwoorden
  7. Avatar

    Paul van der Zee zei op

    Beste STRATO,

    Als PHP hobbyist heb ik mijn eigen website in PHP5.x van scratch af aan zelf gebouwd. Alleen voor m’n weblog maak ik gebruik van WordPress. De laatste keer dat ik de WordPress versie heb geüpdate is alweer even geleden.
    Ik kan de ontwikkelingen heel goed begrijpen en uiteraard wil ik ook dat m’n website meeloopt met deze tijd. Extra kosten wil ik voorkomen, maar ook ik heb wat moeite om me een beeld te vormen wat er voor mijn site nodig is.

    Moet ik een codereview op mijn website loslaten? Dat kan namelijk nogal wat werk kosten, omdat ik veel in procedurele code heb geschreven. Graag ontvang ik daar advies / handvatten in.

    Met vriendelijke groet,

    Paul van der Zee

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste Paul,

      Bedankt voor je vraag.

      Voor de meeste contentmanagementsystemen, zoals WordPress, bestaan handleidingen hoe je het beste kunt upgraden van PHP 5.6 naar een hogere PHP-versie. Ik begrijp echter dat je jouw site voor het grootste deel zelf hebt geschreven.

      In dat geval raad ik je aan de handleidingen van PHP door te nemen: http://php.net/manual/en/appendices.php. Voor de migratie naar elke nieuwe versie bestaat een handleiding (dus van 5.6 naar 7.0, van 7.0 naar 7.1, enzovoort). In deze handleidingen staat precies beschreven welke functies zijn gewijzigd, welke nieuwe features er zijn, enzovoort. Vooral in de release 7.0 bevinden zich grotere wijzigingen ten opzichte van 5.6. De versies 7.1, 7.2 en 7.3 zijn relatief kleinere releases met minder grote veranderingen. Ik raad je dan ook aan om aan de hand van de documentatie van PHP na te gaan welke functies die je op je website gebruikt eventueel zijn gewijzigd.

      Een andere optie is dat je een kopie van je website maakt en deze in een submap op je webruimte plaatst. Middels het php.ini-bestand kun je de PHP-versie voor deze submap wijzigen naar een hogere versie (bijvoorbeeld 7.2). Test vervolgens of je website nog correct werkt. Wanneer dit het geval is, kun je de PHP-versie voor je gehele webruimte aanpassen via onze klantenlogin. Zie hiervoor ook het volgende FAQ-artikel: https://www.strato.nl/faq/hosting/wat-is-strato-php-extended-support/#nodig.

      Ik hoop dat deze tips je verder op weg helpen. Ik hoor het graag wanneer je nog meer vragen hebt!

      Met vriendelijke groet,
      Sjef

      Beantwoorden
      • Avatar

        Paul van der Zee zei op

        Beste Sjef,

        Bedankt voor je eerdere reactie.
        Ik kom daarmee een heel eind.

        Wat me alleen niet lukt, is waar ik het php.ini-bestand of het .htaccess-bestand kan vinden. Met de FAQ kom ik er ook niet uit. Als ik de plek eenmaal weet, dan red ik me wel. Zou je me nog kunnen duiden waar ik moet zoeken?
        Via FileZilla, waarmee ik m’n filetransfer organiseer, tref ik geen map aan waar dit zou moeten staan.

        NB: via FilaZilla heb ik wel al een kopie van m’n website in een aparte map geplaatst. Een subdomein maken is ook zo geregeld.

        Alvast bedankt voor de hulp.

        Met vriendelijke groet,

        Paul van der Zee

        Beantwoorden
        • Avatar

          Sjef Huijbregts zei op

          Beste Paul,

          Goed om te horen dat ik je verder kon helpen.

          Een php.ini-bestand of .htaccess-bestand wordt door STRATO niet standaard voor iedere website aangemaakt. Wanneer je zelf je eigen website hebt geschreven en in de map van de website bevindt zich nog geen dergelijk bestand, kun je deze zelf aanmaken. Het volstaat om in een teksteditor een bestandje aan te maken en dit te hernoemen tot “php.ini”.

          Het bestand plaats je vervolgens in de hoofdmap/root van de website waarop deze betrekking heeft; in jouw geval de map waarnaartoe je het subdomein hebt verwezen.

          Ik hoop dat dit voldoende duidelijk is. Zo niet, hoor ik het graag!

          Met vriendelijke groet,
          Sjef

          Beantwoorden
  8. Avatar

    Henk zei op

    De technische achtergrond van het probleem snap ik nog niet helemaal. Ik maak mijn website met het programma WebSite X5 Evolution 12. Ik begreep van de makers dat als ik hun software update naar versie Evolution 17, zij ondersteunen tot PHP 7.2. Ben ik dan weer “veilig” en hoef ik dan niet jullie ondersteuningsabonnement te nemen? Of snap ik het toch nog niet? Als dit wel de oplossing is, zal ik de website software iets frequenter updaten…
    Met vriendelijke groet,
    Henk

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste Henk,

      Inderdaad, in dat geval raad ik je aan om de software te updaten naar de nieuwste versie, die compatibel is met PHP 7.2. Let er wel op dat je hierna bij STRATO in de klantenlogin je PHP-versie wijzigt naar 7.2. Versie 7.2 wordt nog tot eind 2020 gratis door de PHP-community ondersteund. Voor deze versie heb je dus nog geen Extended Support nodig.

      Met vriendelijke groet,
      Sjef

      Beantwoorden
  9. Avatar

    Ton Coolen zei op

    Als ik php 7.2 activeer is het niet meer mogelijk om inschrijfformulieren te verzenden. De website is gemaakt met Dreamweaver CC2015.
    Graag jullie hulp/advies want ik weet niet hoe ik dit moet oplossen.
    Met vriendelijk groet.
    Ton

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste Ton,

      Dat is natuurlijk een vervelend probleem.

      Waarschijnlijk treedt er een fout op in één of meerdere PHP-scripts. Welke fouten precies optreden, kun je zien in de PHP-errorlogs. Deze vind je in de STRATO klantenlogin via het beheer van je hostingpakket -> “Databases en webspace” -> “Statistiek” -> “Logfiles”. Hier klik je op de button “Toon errorlogs”. In de errorlogs kun je zien welke fout precies optreedt – en in welke regel van welk script.

      Wanneer je dit script zelf schrijft, raad ik je aan de inhoud van het script op de genoemde regel te controleren en eventueel te corrigeren. Wanneer het script door Dreamweaver wordt gegenereerd, raad ik je aan in de documentatie van de software te controleren of deze wel PHP-versie 7.2 ondersteunt en zo niet, of er een updatemogelijkheid bestaat.

      Ik hoop dat dit je verder op weg helpt. Mocht je verdere vragen hebben, hoor ik het graag.

      Met vriendelijke groet,
      Sjef

      Beantwoorden
  10. Avatar

    Greet Heller zei op

    Hallo,
    ik heb de website op Strato zelf gemaakt met een word programma dat u als Strato zelf aanbiedt.‘Live pages’Nu mailt u mij iets dat gaat over PHP. Ik heb geen idee wat u bedoelt en vindt ook dat je zo niet met je klanten om moet gaan.

    ik weet echt niet waar u het over heeft. Zou niet weten wat ik moet doen. Heb ook geen zin in extra kosten!

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste Greet,

      Bedankt voor je vraag. Vervelend dat hier onduidelijkheid is ontstaan.

      Ik zie dat je inmiddels contact hebt gehad met mijn collega’s van onze klantenservice. Samen met hen is de PHP-versie nu gewijzigd naar een recente versie. Er zullen dan ook geen extra kosten ontstaan.

      Met vriendelijke groet,
      Sjef

      Beantwoorden
  11. Avatar

    Annette zei op

    Ik heb een melding ontvangen dat ik gebruik maak van PHP 7.0. In de database sectie staat deze echter op de aanbevolen PHP. Dat lijkt niet overeen te komen met uw melding. Moet ik dan nog ergens anders iets aanpassen of zou dit automatisch aangepast moeten worden? Website is gebouwd mbv wordpress.

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste Annette,

      Bedankt voor je vraag. Ik heb het even voor je nagekeken. Op dit moment gebruik je inderdaad een recente PHP-versie, PHP Extended Support zal dus niet geactiveerd worden. De e-mail die je op 23 januari van ons hebt ontvangen, kun je negeren. Onze excuses voor de verwarring.

      Met vriendelijke groet,
      Sjef

      Beantwoorden
  12. Avatar

    M. Ritsema zei op

    Door deze actie ben ik genoodzaakt kosten te maken terwijl ik de website eigenlijk wil sluiten. Het contract loopt door tot juni dacht ik. Kosten voor websitebouwer of kosten voor onderhoud, beiden is geld over de balk. Wat moet ik doen?

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Goedemorgen!

      Wanneer je binnenkort stopt met je website, is het eventueel geen groot probleem wanneer bepaalde elementen van je website niet meer correct werken zodra je overstapt naar een nieuwe PHP-versie. Eventueel kun je er ook voor kiezen om nu al je website offline te halen (bestanden van je webruimte halen, database verwijderen). Zo voorkom je dat er kosten voor PHP Extended Support in rekening worden gebracht.

      Je kunt er ook voor kiezen de huidige website zo te laten, en de PHP-versie niet te wijzigen. In dat geval zullen wel kosten voor PHP Extended Support in rekening worden gebracht. Deze worden maandelijks gefactureerd, en zullen natuurlijk stoppen zodra je contract afloopt.

      Je kunt voor verder advies ook contact opnemen met mijn collega’s van onze klantenservice.

      Met vriendelijke groet,
      Sjef

      Beantwoorden
  13. Avatar

    Gerrit van der Beek zei op

    Ook ik heb geen idee of een overstap nadelig is. Kunt u even kijken ?
    Er is een aparte pagina die wordt beschermd met inlognaam en wachtwoord . De site is voornamelijk via HTML opgebouwd .

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste Gerrit,

      Bedankt voor uw vraag. Ik heb helaas geen toegang tot de scripts op uw webruimte. Ik kan dan ook niet zien welke elementen van uw website eventueel beïnvloed worden bij een overstap naar een nieuwere PHP-versie. HTML-pagina’s worden in ieder geval niet beïnvloed.

      Ik raad u aan op uw webruimte te kijken welke PHP-scripts u gebruikt voor welke elementen op uw website. Het zou kunnen dat het logingedeelte bijvoorbeeld gebruikmaakt van PHP. Wanneer u overstapt naar een nieuwe PHP-versie, controleert u direct de elementen die gebruikmaken van PHP. Direct naar de overstap kunt u eventueel nog terug naar PHP 5.6. Zodra u eenmaal uit de klantenlogin uitlogt, is dit niet meer mogelijk.

      Ik hoop u hiermee verder op weg te hebben geholpen. Mocht u nog vragen hebben, hoor ik het graag.

      Met vriendelijke groet,
      Sjef

      Beantwoorden
  14. Avatar

    Mario zei op

    dag wat zijn de consequenties van het updaten van PHP, dat snap ik nog niet helemaal. En hoe doe ik dat? Ik werk met een theme via wordpress en de site wordt bij jullie gehost. Ik kan dit allemaal niet zo goed overzien eerlijk gezegd. het klinkt allemaal als abracadabra. wat is jullie advies om het goed te regelen?

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste Mario,

      Bedankt voor je vraag. Wanneer je de meest recente versie van WordPress hebt geïnstalleerd, dan is deze in ieder geval compatibel met de nieuwste PHP-versies. Het kan echter zijn dat het gebruikte thema of de gebruikte plugins niet (volledig) compatibel zijn. Daarom raad ik je aan voor het thema en de plugins die je gebruikt te controleren met welke versie van WordPress en welke versie van PHP deze compatibel zijn. Dit kun je meestal terugvinden op de website van de betreffende thema’s/plugins. In het algemeen geldt dat wanneer er regelmatig updates worden uitgebracht voor de plugins en voor je thema, deze ook compatibel met de nieuwste PHP-versies moeten zijn.

      Vervolgens check je in de back-end van WordPress of er updates beschikbaar zijn voor je WordPress-versie en thema’s. Zorg ervoor dat je up-to-date bent.

      Tot slot kun je in de klantenlogin van STRATO de PHP-versie wijzigen. Hoe je dit doet, lees je hier. Check na het wijzigen van je PHP-versie meteen of je website nog correct werkt. Zodra je namelijk uit de klantenlogin uitlogt, kun je niet meer terug naar de oude PHP-versie.

      Ik hoop dat dit je verderhelpt. Wanneer je nog meer vragen hebt, kun je ook contact opnemen met mijn collega’s van onze klantenservice.

      Met vriendelijke groet,
      Sjef

      Beantwoorden
  15. Avatar

    Gina zei op

    mijn php is omhoog gezet naar de nieuwste versie geloof ik maar nu kan ik niet meer in mijn admin komen op wp. Ik krijg een witte pagina. De website zelf is nog wel online. Wat nu? Ik ben een hobbyist en heb geen verstand van backend. Dringend hulp nódig.

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste Gina,

      Dat is natuurlijk erg vervelend om te horen. Wanneer ik naar de login-pagina van je WordPress-site ga, zie ik een foutmelding die erop wijst dat de fout wordt veroorzaakt door je gebruikte WordPress-thema “Dazzling”, en specifiek de Popular Posts Widget.

      Om weer in te kunnen loggen, zou je het gebruikte thema tijdelijk een andere naam kunnen geven. Zo zal WordPress automatisch terugvallen op een ander geïnstalleerd thema. Hoe je dit doet, en hoe je in WordPress een fout met een “witte pagina” kunt verhelpen, lees je in dit blogartikel.

      Daarnaast raad ik je aan om over dit probleem contact op te nemen met de ontwikkelaars van het gebruikte thema. Waarschijnlijjk zal het probleem bij hen bekend zijn en kunnen ze je een oplossing bieden. Je kunt je vraag bijvoorbeeld stellen op hun supportforum.

      Ik hoop dat je het probleem snel kunt verhelpen!

      Met vriendelijke groet,
      Sjef

      Beantwoorden
  16. Avatar

    Praktijk sketch zei op

    Zou u mij stap voor stap kunnen aangeven welke stappen ik nu precies moet doorlopen, waar ik dit precies kan vinden, hoe ik kan kijken of alles van mijn website dan nog zal functioneren etc ?

    bedankt

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Goedemiddag,

      Bedankt voor uw vraag. Ik zie dat u de meest recente versie van WordPress heeft geïnstalleerd. Deze is in ieder geval compatibel met de nieuwste PHP-versies. Het kan echter zijn dat het gebruikte thema of de gebruikte plugins niet (volledig) compatibel zijn. Daarom raad ik u aan voor het thema en de plugins van uw WordPress-website te controleren met welke versie van WordPress en welke versie van PHP deze compatibel zijn. Dit kunt u meestal terugvinden op de website van de betreffende thema’s/plugins. In het algemeen geldt dat wanneer er regelmatig updates worden uitgebracht voor de plugins en voor uw thema, deze ook compatibel met de nieuwste PHP-versies moeten zijn.

      Vervolgens controleert u in de back-end van WordPress of er updates beschikbaar zijn voor uw WordPress-versie en thema’s. Zorg ervoor dat alles up-to-date is.

      Tot slot kunt u in de klantenlogin van STRATO de PHP-versie wijzigen. Hoe u dit doet, leest u hier. Check na het wijzigen van de PHP-versie meteen of uw website nog correct werkt. Zodra u namelijk uit de klantenlogin uitlogt, kunt u niet meer terug naar de oude PHP-versie.

      Ik hoop dat dit u verderhelpt. Wanneer u nog meer vragen heeft, kunt u ook contact opnemen met mijn collega’s van onze klantenservice.

      Met vriendelijke groet,
      Sjef

      Beantwoorden
  17. Avatar

    Jurian zei op

    Beste Strato,

    Wij hebben al een aantal jaren de website Snelwrapfolie draaien.
    Echter hebben nu een probleem. Wij moeten de site updaten naar een nieuwere PHP versie alleen als wij dit doen raken wij alle scriptings kwijt en handmatige instellingen.
    Wij draaien op websitebaker WB2.8.3SP1 en hebben daar een PHP 5.6 versie voor nodig.
    Kunnen wij onze shop bij jullie laten draaien en is te gemakkelijk te realiseren zonder grote problemen?

    In afwachting

    Jurian
    Team Snelwrapfolie

    Beantwoorden
    • Avatar

      Sjef Huijbregts zei op

      Beste Jurian,

      Bedankt voor je vraag. Enkel voor bestaande klanten, die in het verleden hun website met PHP 5.6 hebben gemaakt, is deze versie bij STRATO nog beschikbaar (wanneer de dienst PHP Extended Support wordt afgenomen).

      Wanneer je een nieuw hostingpakket bij STRATO afneemt, kun je kiezen uit de recente PHP-versies 7.1, 7.2 en 7.3. PHP 5.6 is in dat geval dus niet beschikbaar.

      Overigens zou ik je aanraden om altijd gebruik te maken van een recente PHP-versie waarvoor nog veiligheidsupdates worden uitgebracht. Bij oudere versies loopt je website een veiligheidsrisico.

      Met vriendelijke groet,
      Sjef

      Beantwoorden

Je kunt pas een reactie plaatsen nadat je ons privacybeleid en cookies hebt geaccepteerd. Om privacyredenen mogen wij jouw persoonsgegevens anders niet verwerken.

Klik onderaan de pagina op de blauwe button OK. Nadat je de pagina opnieuw hebt geladen, kun je een reactie achterlaten.

Deze website maakt gebruik van cookies voor onder andere Google Analytics. Deze melding verdwijnt zodra je de cookies hebt geaccepteerd. Meer informatie

OK